
Most 3D objects have flawlessly smooth surfaces, which makes them too 
perfect for certain contexts. The usual procedure for giving a surface a little
bit of roughness is to fake deformations using so-called Bump Maps. In fact,
the Bump Map isn’t a feature of the surface itself, it is a feature of the cam-
era. Most of the time, Bump Mapping is sufficient and it’s very economical
in terms of rendering time. It fails, however, when you need very pro-
nounced deformations and bulges that contrast sharply with the back-
ground.

Enter Displacement Mapping—a technique that doesn’t fake the deforma-
tion for the camera but actually deforms the surface using the gray tones of a
procedural texture or a picture. Unfortunately, we don’t see these deformations
in the modeling views.We have to render them.

This tutorial consists of two parts that fit together nicely.We start by using
subdivision surfaces to model a tall, thin man with a small head.With a little

bit of practice this task takes only a few minutes. (Before the era
of subdivisions it was a matter of at least an hour.) If you don’t
have Maya Unlimited you can achieve similar results by using
the same split and extrude tools and applying the Polygons >
Smooth operation at the very end. If you want to skip the mod-
eling part or keep it for later, just use any kind of primitive and
continue with the displacement part of this tutorial.

1 Create a polygon cube.
2 Choose Modify > Convert > Polygons to Subdiv to convert
the cube into a subdivision surface.
3 Assign a new material to the subdivision cube.

If you inadvertently textured the cube (which is actually just
the outer skin of the subdivision surface and not the surface
itself ) instead of the subdivision surface, undo the assignment.
Select the actual subdivision surface polyToSubdShape1 (for
example, in the Hypergraph) before you assign the material
again. For the following actions, right-click the subdivision object
and use the context menu.

4 Switch to Polygon mode (see Figure 10.1).

KNOBBLY MAN

How do I construct a figure whose surface is rougher
than the usual 3D character’s?
Theme: Modeling, Rendering
Techniques and tools used: Subdivision Surfaces, Split
Polygon Tool, Extrude Faces, Displacement Shader

Figure 10.1 A polygon cube converted �
into a subdivision surface. Its context 
menu allows us to make the original 

polygon visible.
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You can model with subdivision surfaces in two general modes. One is
using the polygon tools, the other is using tools from the world of Nurbs
modeling. The classic polygon modeling tools are ideal for achieving higher
geometric resolution (for example, in the area where the legs come out of
the torso).That’s why we’ll perform most of the modeling for our guy in 
Polygon mode.

1 Choose Edit Polygons > Split Polygon Tool to break the cube’s bottom
face in two (see Figure 10.2). Just eye it, don’t try to be too precise—our 
character isn’t going to enter a beauty contest. Finish the Split command 
by pressing Enter.
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� Figure 10.2 Use the Split Polygon
Tool to split the lower face of the cube
into two parts.

� Figure 10.3 The Extrude Tool creates
a locally higher density of geometry.
Here we use this density to start pulling
out faces for modeling the legs.

� Figure 10.4 A few extrudes later
and the legs are finished—not at all
perfect, but they’re legs. The last
extrudes (horizontal this time) will
make the feet.

� Figure 10.5 View from the side
for more precise modeling of the
ends of the feet.

� Figure 10.6 The lower extremities
are completed—with a little practice it
takes only a couple of minutes.
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2 Use the context menu to make
the Faces visible. Select the newly
created two bottom faces of the
cube. Choose Edit Polygons >
Extrude Face to pull new geometry
out of these faces (see Figure 10.3).
Clicking on one of the scaling
cubes of the tool puts the tool into
scaling mode. Homogeneously
scale down the extruded surfaces a
little. Use the tool’s arrow to trans-
late them down a bit.
3 Don’t lose your selection, press
the G key to apply the extrude com-
mand again, this time to the freshly
extruded faces. Pull the legs out of
the torso by applying the command
two or three more times.With the
last extrude, create faces of a size
that can be used to pull the feet out
to the front (see Figure 10.4).
4 When extruding and scaling 
the feet, use the side and top 
views to work more precisely (see
Figure 10.5).

1 Use the Split Polygon Tool on 
the sides of the torso and start
extruding the arms (and, if you like,
fingers).The extrude command
works symmetrically, so you can
extrude geometry simultaneously
for the right and left arms (see 
Figure 10.7).
2 Extrude the top face of the subdi-
vision polygon, scale down the
cross-section of the neck and start
pulling out the neck and head (see
Figure 10.8).
3 Check the whole figure, adjusting
faces to your taste. Keep in mind
that you don’t have to just translate
and scale, you can also rotate faces
(see Figure 10.9)!
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� Figure 10.7 Working the upper 
body: Here are the first two extrudes 

for the arms.

� Figure 10.8 The first two extrudes for
the neck and head.

� Figure 10.10 The context menu of the
subdivision surface lets you switch

between different levels of hierarchy. Finer
levels let you work more locally.

� Figure 10.9 Aftermath: rotation of the
back of the head.
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In the Channel Box, you can see that after all the extrudes you’ve done the
surface’s construction history contains a lot of information we don’t need any
more. Deleting history using the Edit > Delete by Type > History command
also makes the scene a little lighter.

What you don’t delete by deleting the surface’s history is its identity as a
subdivision surface. By using the context menu and the commands Coarser
and Finer, you can switch from one level of hierarchy to the next in order to
work more globally or locally, in polygon as well as in standard mode (see
Figure 10.10).

You don’t need to add too much detail to your fellow at this point, like a
nose, shoulder blades, or toes.The Displacement Shader might wipe away
features as small as a nose or shoulder blades anyway.

1 In the Attribute Editor of the surface’s shading group (in the case of a
Blinn shader, its name will be blinn1SG), click the checker icon next to 
Displacement Mat.
2 The Create Render Node window opens (see Figure 10.11). Chose a texture
here that will deform the character according to its gray values, such as the
Solid Fractal. For the mapping method, select “As projection.” The projection
will make sure that the texture is distributed evenly over the whole object.
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� Figure 10.11 This is how to create 
a Displacement Map of a 3D texture by
projection: Open the Attribute Editor of 
the Shading Group, click the checker icon
next to Displacement Mat., and in the 
Create Render Node window choose 
“As projection” for the method and, for 
example, Solid Fractal as its structure.
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� Since you’ll see no change in the modeling view, render the scene.

Rendering takes a while, maybe several minutes, depending on the geom-
etry and material used and, of course, the speed of your computer.The results
really clarify the difference between Displacement Mapping and Bump Map-
ping. In Figure 10.12, the character in the front was assigned the same Solid
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Figure 10.12 These two characters �
possess the same geometry and the same
texture; the only difference is the way the

texture was applied. The unevenness of the
front figure comes from a Bump Map,
whereas the back figure’s texture is a 

Displacement Map. The edges of the front
figure look smooth, but the Displacement
Mapping on the other creates real bulges.

Although no extra tuning was applied to
the mapping procedure, the Displacement

Map thickens the character drastically
whereas the Bump figure basically shows

the original size of the modeled geometry.

� Figure 10.13 The wireframe cube at
the character’s feet determines the dimen-
sion of the Displacement Map. The smaller
that cube, the more frequently the texture

is repeated on the object.

Figure 10.14 The 3D placement �
object now covers the whole character.To

the left is the rendered scene. With the
marked icon you can save rendered pictures

to memory.They won’t be deleted until you
exit Maya (or until the program crashes).
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Fractal texture as the character in the back, but the texture
was assigned as a Bump Map rather than as a Displacement
Map (as for the character in the back).The surface of the
front figure looks uneven, but its edges look totally smooth
against the background.

Displacement Mapping has more or less effect, depend-
ing on how large you constructed your knobbly figure.
There are two ways to adjust the strength of the effect. One
is by changing the density at which the texture is mapped
onto the geometry. In the modeling views you can see a
wireframe cube named place3dTexture1; that’s the tool
that lets us make these changes (see Figure 10.13).

The second way to adjust the displacement texture 
is by using the texture’s gray values. Displacement Map-
ping, like Bump Mapping, makes use of only the bright-
ness (the alpha channel, not the color) of a texture in
order to create geometric deformations. For most tex-
tures, such as the Solid Fractal, you’ll find the grayscale
entries under the Color Balance section in the Attribute
Editor. First start with very dark, almost black values for
the colors and a very low value for the Alpha Gain (see
Figure 10.15).

Basically you let the character grow in size by applying
a bright texture. A Displacement Mapping that finds only
black will leave the figure unchanged. If the texture shows
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� Figure 10.15 The texture’s Attribute
Editor. In the upper area are the parame-
ters responsible for the structure of the
fractal, lower down are the settings for
gray, which are responsible for the amount
of deformation. The main parameters
when dealing with a Displacement Map
are Color Gain and Alpha Gain. Higher 
values mean more white, which leads to 
an enlarged figure. When the Dis-
placement Map finds only black it
leaves the geometry untouched.

Figure 10.16 A character �
that looks sculpted from clay.
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areas of distinct changes in brightness, the character
will look very bulgy, with the bright areas of the texture
corresponding to the bulges on the surface.

You’ll have to use a lot of trial and error to find a
proper combination of settings to achieve the result
you have in mind. Unfortunately, IPR doesn’t work with
Displacement Maps, which means you have to deal with

extended periods of test rendering. Use the render
window’s option to render smaller sizes or only
parts of pictures.

With subdivision modeling and Displacement
Mapping you have two strong tools for efficiently

creating complex characters that look like they’re
made of clay (see Figure 10.16) or maybe hammered
from metal (see Figure 10.17).To create a finer tex-
ture, you might add a Bump Map in addition to the
Displacement Map.The bumps can then work as
tiny deformations on the larger deformations.

The modeling process leaves your character
with very unevenly distributed UV texture coordi-
nates.You would see this if you had used Normal
rather than Projection as your method of map-
ping. In order to fix these texture distribution
problems you need to create a new UV tex-
ture map, for example by applying the
command Automatic Mapping, which
you’ll find in the Subdiv Surfaces menu.

A projected texture like the one we’re
dealing with here doesn’t care about UV 

coordinates. But as soon as you start ani-
mating the character, you’ll have to

bake the projected texture onto the
geometry. Otherwise it will look as if

when the character moves it’s
swimming through the

texture.You find the
command for baking
textures in the Hyper-
shader: Choose Edit >
Convert to File Texture. If you
want to use the sophisticated tools

for polygon texture mapping, save your scene and then convert 
the subdivision creature into a polygon creature (choose Modify >

Convert > Subdiv to Polygons).

54 Modeling

Figure 10.17 �
Hammered-metal knobbly guys.
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� Figure 10.18 Knobbly guys 
hammered out of gold.

And now for something completely 
different: Pressed the A or F key recently?
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